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6.3. Overview of the model interface 

6.3.1. Installing GreenMod II 

When you are ready to install GreenMod II, follow these steps: 

Step1:  Insert GreenMod II CD into your CD-ROM drive. The Install program appears 
automatically after you insert the CD. Alternatively click on the Setup.exe file in the GreenMod 
II CD to install the program. 

Step 2: Follow the on-screen instructions to complete the installation. In case the following 
massage appears during the installation process “The destination file is in-use” click Ignore 
button. 

Step 3: Click on Finish to complete the installation. 

6.3.2. Launching GreenMod II 

Follow these steps to launch GreenMod II. 

Step 1: Click on the Start Menu. 

Step 2: Select Programs, then locate GreenMod II. 

Step 3: Click on GreenMod II and the program opens. 

6.3.3. Exiting GreenMod II 

When you are ready to exit from GreenMod II, you can select menu command Exit from the 
menu item File or just close the window. 

6.3.4. Program overview 

Main window 
After you successfully launch GreenMod II, the GreenMod II Main Window appears. The Main 
window is shown below: 
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Main window. 

Before you begin working with the program, you should familiarize yourself with the parts of 
this window, listed below. This manual will refer to these terms throughout. An explanation of 
each part follows: 

• The Menu bar. 

• The  Tool bar. 

The Menu Bar 
 

 

The Menu Bar. 

The menu bar is located across the top of the screen just below the title bar and contains four 
items: File, EcoMod, Tools and Help. Below, you will find a description of each of these menus 
and their corresponding commands. 

File Menu 

Click on File in the menu bar. It contains the following commands: 

New project… - click on this command, if you want to create new project. The window Add 
new project will appear. 

The Menu Bar

The Tool Bar
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New scenario… - click on this command, if you want to create new scenario. The window Add 
new scenario will appear. 

Select GAMS program – click on this command, if you want to select the GAMS version to be 
used. The list of all the GAMS versions installed on your computer will be shown and you will 
be able to choose one of them. 

Exit – select this option to exit from GreenMod II. 

EcoMod Menu 
This menu item is to provide you with information about EcoMod Network. 

Tools 
This menu item is to provide optional specific tools  

Help 
This menu item is to provide help on the interface. 

 

The Tool Bar 

 

The Tool Bar. 

The tool bar is located just below the menu bar and allows you quick access to certain 
functions. You can access a brief explanation of each button by letting the mouse pointer rest on 
it. Each button is defined below. 

Button Function 

   Click on this button to exit GreenMod II. This is the same as clicking on Exit item of the 
File Menu. 

   Click on this button to start new project. This is the same as clicking on New Project… 
item of the File Menu. 

   Click on this button to start new scenario. This is the same as clicking on New Scenario… 
item of the File Menu. 

   Click on this button to select the GAMS version to be used. This is the same as clicking 
on Select GAMS program item of the File Menu. 

   Click on this button to get help on the interface. 

The other buttons. 
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    Button Help. The same as tool item .  

    Button Back. It redirects you to the previous tab. When the tab Title is active, this 
button is not. 

    Button Next. It redirects you to the next tab. When the tab Projects is active, 
this button is not. 

Creating new project/opening old project 
After you start up the program activates the Projects tab as shown here  

 Projects tab 

The Project tab allows you to access old projects, delete them and create new ones. Drop-down 
list Project allows you to choose from the list of the existing projects and information about the 
chosen one is displayed in the window below. After a certain project is chosen in the drop-
down list, you can delete it using button Delete project. 

Note: button Project information is not working yet. It is under development.  

In order to create a new project click on the button Add project. In the field Project of the Add 
new project window write down a project name and in the field Project description any 
relevant information about a project. For each project user must decide if he or she wants to use 
a default baseline or to create a new one. The drop-down list Baseline allows you to choose 
between using the Default baseline for your project and creating you own Custom baseline (for 
more details see § III.1). Then fill in the field Baseline Description using relevant information 
about your baseline. After all fields are filled in click the OK button to create the project or the 
Cancel button to abort its creation.  



Project CP/51 – «GreenMod II: Dynamic Regional and Global Multi-Sectoral Modelling of the Belgian Economy for 
Impact, Scenario and Equity Analysis » 

 

SPSD II - Part I - Sustainable production and consumption patterns - Energy 6/15 

 

 Add new project window 

Creating new scenario/opening old scenario 
An existing project can incorporate a range of different scenarios. In order to access the old 
project scenarios choose the right project name using drop-down list Project in the tab Projects 
and specify which scenario you would like to work with using drop-down list Scenario. After the 
scenario has been chosen it is possible to delete it using the button Delete scenario, edit the 
scenario using the button Edit scenario or view its simulation results using the button View 
results.  

In the case when a new scenario should be created you can add it to the chosen existing project 
using the button Add scenario.  After the button is clicked the Add new scenario window 
appears together with the name and description of the chosen project. In order to create a 
scenario you should fill in the Scenario and the Scenario description fields. After all fields are 
filled in click the OK button to create the scenario or the Cancel button to abort its creation.  

 

Add new scenario window 

Creating a shock file 
After a new scenario is created or you chose to edit an old one, the program takes you to the 
Scenario manager tab.  
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Scenario manager tab 
 
This tab allows you to choose the time horizon for your scenario using the corresponding 
textbox.  

Note: the upper limit for the chosen time horizon is the year 2035 and by default any scenario 
starts from the year 1998. 

After the right time horizon has been chosen click on the Next button or on the tab Variable 
selection. Variable selection tab allows you to select economic variables, which you would like 
to change in your scenario. The variables are chosen from the list provided in the left tab 
window and are grouped by categories. To choose a variable from the list you should click on 
its name. This opens a range of windows in the middle of the tab, which provide the sets of 
sectors, commodities or regions over which a variable is defined. The combination of these sets 
depends upon a variable type. For global variables (such as total governmental transfers) no sets 
are provided since they do not vary with sectors, commodities or regions.   

In order to add a variable to the shock file you should select names of sectors, commodities or 
regions for which you would like it to be changed using the lists in the middle of the tab and 
click on the >> button.  Respective variable will be moved to the right tab window together 
with the values of its sets. In order to remove a variable from the right tab window you should 
select it and click on the << button. In the case you want to remove all selected variables from 
the right tab window use the Clear button at the bottom of it.  

Note: in order to select a variable for all sectors, commodities and regions it is defined over, 
you should select it in the left tab window and click directly on the >> button.  
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Note: to select a range of sets elements (sectors, commodities or regions) use TAB or Ctrl 
buttons.  

              
Variable selection tab 

After all shock variables are chosen and placed into the right window of  the Variable selection 
tab you either click on the Next button or on the tab Shocks.  

The tab Shocks allows you to specify how you would like to change the shock variables. When 
you get to the tab Shocks you find all the names of the variables you have chosen at the 
previous step under the field Variables. By clicking on the “+” sing to the left of the variable 
name you open its sets (sectors, commodities and regions) and can specify your shocks 
differently for different elements of these sets.  Under the field Parameters you see sets elements 
a variable is defined over and under the field Value you see variable initial value.  

Shocks can be specified either in percent (%) or in value (fixed amount = fa). All shocks are 
given with respect to the initial value of a variable. In order to specify your shock in percent you 
should type shock value followed by % sign. In order to give a shock in value you should type 
fa after your shock level.  



Project CP/51 – «GreenMod II: Dynamic Regional and Global Multi-Sectoral Modelling of the Belgian Economy for 
Impact, Scenario and Equity Analysis » 

 

SPSD II - Part I - Sustainable production and consumption patterns - Energy 9/15 

       
Shocks tab 

In order to assign the same shock to a range of cells, select them and right click on the mouse. In 
the appearing menu choose Insert. The following window appears: 

 

Shocks increment window 

The window allows you to set a value for the shock using the field Increment and to choose its 
type: percentage change or fixed amount using the field Type of incerment. The chosen shock is 
assigned to all selected cells. 

Note: the field Functional form is not active, it is under development.  
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In order to specify the same shock over all sets of a variable, you should leave the variable 
closed and modify the row associated directly with the variable name as shown below:  

 

Shocks tab 

Running a simulation 
After all shocks have been specified you can start simulations with the model by clicking on Run 
button. This will start GAMS calculations in the DOS window. If during the simulations you 
would like to stop GAMS use the button Exit GAMS on the Shocks tab or just close the DOS 
window.  
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DOS window 

Viewing results 
After the simulations are finalised the DOS window closes and the program takes you to Results 
tab. 

 

Results tab 

The Results tab allows you to access simulation results in the form of tables and graphs. The 
results are grouped according to their categories presented at the left tab window. By selecting 
specific variable of interest from each category you can view its values in the form of table or a 
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graph at the right tab window. In order to switch between the two presentation forms use Table 
and Graph tabs.  

Left widow of the Results tab contains All, Main and Custom tabs. Tab All allows you to access 
the full range of model results whereas tab Main contains only most important variables.  You 
can also create you own list of most used model results by using tab Custom.  

 

Custom tab of the Results tab  

In order to create or change your own custom list of model results click on the button 
Customize. It opens Custom tables window which is quite similar to Variables tab in its 
structure and allows you to modify your custom tables by adding one from the list in the left side 
of the window using > button or remove already chosen table from the custom tables using < 
button. Button << is used to remove all tables from the custom tables list.  

Note: to select a range of tables use TAB or Ctrl buttons.  

After the selection is completed click on the Create button to modify custom tables.  
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Custom tables window 

Exporting results to Excel 
The program gives you the possibility to export both tables presented in Results tab and all other 
model results to Excel. 

In order to export tables to Excel click on the Export tables to Excel button of the Results tab. 
There appears Export to Excel window.  

Export to Excel window 

By selecting table names on the left side of the window and clicking on > button you can add 
them to the list of tables to be exported to Excel (on the right side of the window). In order to 
remove already chosen tables use < button. Buttons << and >> allow you to remove or add 
all tables respectively. There is a possibility to open created Excel file after it has been 
generated. In order to activate it check the Open excel Workbook box. After the selection is 
completed click on the Export button to start exporting. First Explorer window opens, where 



Project CP/51 – «GreenMod II: Dynamic Regional and Global Multi-Sectoral Modelling of the Belgian Economy for 
Impact, Scenario and Equity Analysis » 

 

SPSD II - Part I - Sustainable production and consumption patterns - Energy 14/15 

you can choose location and name of you excel file. After you have chosen name and location 
click on OK button to finalize the process.  

In order to export all other model results to Excel click on the Export variables to Excel button 
of the Results tab. There appears Export to Excel window.  

Export to Excel window 

Exporting procedure is similar to the one described above. The difference between the two 
exporting procedures is the range of results available for exportation.  

Printing and copying the results, shocks and graphs 
If you would like to print out the Shock table or the Results table or the chart you can select the 
File menu item Print Shocks, Print Results or Print Chart respectively. Also you can copy any of 
these objects and paste into a text file or Excel worksheet. To copy tables (first select cells you 
would like to copy) and charts you should click on the right mouse button over an object and 
select an action from a popup menu. 

 

Saving scenarios 
After you work with the scenario and its results is finalized and you want to save your scenario 
use one of the following possibilities: 

1. Click on the button Main window or select the File menu item Main window and 
answer Yes when the program asks you whether you want to save scenario.  By clicking 
on this button you go back to the Projects tab and can work further by creating new 
projects and scenarios.  

2. Go to the menu File and choose Save. In order to go back to the Projects tab choose 
Main window in the menu File.  

3. Close the program window and answer Yes when the program asks you whether you 
want to save scenario.   
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6.3.5. Special features 

Creating custom baseline 
While creating a new project you can chose whether you are going to use default baseline or 
create your own custom baseline. Creation of the custom baseline is similar to creating a 
scenario and uses the same Variables, Shocks and Results tabs. You should remember that in 
case of the custom baseline shocks of the alternative scenarios should be specified with the 
respect to this baseline not default one. One project may be associated with a single custom 
baseline. In case you want to generate another baseline you have to create a new project.  

After you have chosen that you are going to create a custom baseline for the new project, you 
are taken consequently to Variables, Shocks and Results tabs. In the process of baseline creation 
you can switch between these tabs to modify your shocks and analyze results. Once you are 
satisfied with them, save your baseline using Save button in the File menu or click on the Main 
window button (Main window item in the File menu). After that you can go back to the Main 
window where you can continue by creating an alternative scenario for your project.  

 


